Welcome to www.JeepStrokers.com!!
Not yet a registered user? You are required to Register before you can post within this topic.

4.9 stroker engine

Performance mods and Advanced Stroker discussion.
superstingray77
I made it to triple digits!
I made it to triple digits!
Posts: 141
Joined: February 28th, 2012, 6:31 pm
Stroker Displacement: 4.7
Vehicle Year: 1999
Vehicle Make: jeep
Vehicle Model: WJ

Re: 4.9 stroker engine

Post by superstingray77 » August 30th, 2012, 6:29 am

Trust me... tuning it will make a huge difference across the board.
Even if it did make 315 at power peak, the engine will drive like a$$ on the street if the AFR/Spark tables arent plotted to match because the entire remainder of RPM band wont be optimized and thus provide poor acceleration up to the peak RPM. Off the dyno and in the real world its all about the area under the curve. Broadest curve wins even if the motor is rated for less peak hp.

Titan... well theres a reason a just built my second stroker after the first only lasted 2000 miles. :-(

FFOLKES
Posts: 2
Joined: February 21st, 2011, 9:01 pm
Stroker Displacement: 4.9
Vehicle Year: 1998
Vehicle Make: JEEP
Vehicle Model: TJ

Re: 4.9 stroker engine

Post by FFOLKES » September 17th, 2012, 5:06 pm

:doh: I got scammed the same way.........wasted thousands of dollars ...... I never will buy a Titan product again

FFOLKES
Posts: 2
Joined: February 21st, 2011, 9:01 pm
Stroker Displacement: 4.9
Vehicle Year: 1998
Vehicle Make: JEEP
Vehicle Model: TJ

Re: 4.9 stroker engine

Post by FFOLKES » September 17th, 2012, 5:20 pm

:boom: I have a jeep that gets photos taken at gas stations and stop signs.......... I have a Titan 4.9 and that was the biggest mistake of my life
if you got to shoot yourself in the foot go with ATK at least they are winning Baja races :doh:

superstingray77
I made it to triple digits!
I made it to triple digits!
Posts: 141
Joined: February 28th, 2012, 6:31 pm
Stroker Displacement: 4.7
Vehicle Year: 1999
Vehicle Make: jeep
Vehicle Model: WJ

Re: 4.9 stroker engine

Post by superstingray77 » September 18th, 2012, 7:32 am

Ditto on the Titan and I built my first one using a kit. Cam wiped at 2k miles because their head had seat pressures at >135#. No refund, no recourse rebuilt entire engine again at my cost, wiped the bearings, oil pump, crank, rings, etc. Had to polish and re-hone and start over. The parts I eventually got from 505 appeared to be solid (rods/pistons) but the head work was dirty and appeared rushed and unfinished, aside from losing all my stuff in shipping, having pistons show up destroyed, and all sorts of @#$%^&*.

Post Reply

Who is online

Users browsing this forum: No registered users and 12 guests