Welcome to www.JeepStrokers.com!!
Not yet a registered user? You are required to Register before you can post within this topic.

New 4.6 Stroker Idles fine Stalls at stop lights/stop signs

Performance mods and Advanced Stroker discussion.
Post Reply
mrd05d
Posts: 7
Joined: December 18th, 2020, 9:59 am
Vehicle Year: 2000
Vehicle Make: Jeep
Vehicle Model: Grand

New 4.6 Stroker Idles fine Stalls at stop lights/stop signs

Post by mrd05d » September 3rd, 2021, 5:27 pm

2003 Jeep TJ Automatic 4.6l. New Crankshaft Position Sensor since the old one was cracked at the eyelit. New TPS. New IAC (after cleaning the old one). Put in a TJ Big 7 kit (2g wires).

Pulled TB and cleaned it squeaky clean throughout.

Once it enters closed loop Idle is sitting at 720 ish and will idle all day without issue. After driving for a minute say up to 40mph then come to a stop sign or stoplight engine stalls. Starts right back no and will idle/run fine again until increased speeds then drop back down to idle at stop... stalls.

Getting a little frustrated to be honest. :frustrated:

User avatar
Cheromaniac
Senior Member
Senior Member
Posts: 2980
Joined: March 8th, 2008, 12:58 pm
Stroker Displacement: 4563cc
Vehicle Year: 1992
Vehicle Make: Jeep
Vehicle Model: Cherokee
Location: Cyprus
Contact:

Re: New 4.6 Stroker Idles fine Stalls at stop lights/stop signs

Post by Cheromaniac » September 3rd, 2021, 10:00 pm

Does your speedo work correctly? The problem could be a faulty vehicle speed sensor (VSS).
1992 XJ 4.6 Stroker - 5MT - Stroker build-up, Stroker "recipes" Sold :cry:
2006 Mustang GT - 5MT - Modded
midlife crisis car. :D

mrd05d
Posts: 7
Joined: December 18th, 2020, 9:59 am
Vehicle Year: 2000
Vehicle Make: Jeep
Vehicle Model: Grand

Re: New 4.6 Stroker Idles fine Stalls at stop lights/stop signs

Post by mrd05d » September 4th, 2021, 10:06 am

The speedo works fine, as it did prior. It's about 4pmh off because of larger tires but no glitches, jumping, or anything or anything.

It also seems to drop rpm when depress the accelerator for a split second. So if it's idling at 720 and I kick it to go it drops to 650 before it comes back up to rev.

mrd05d
Posts: 7
Joined: December 18th, 2020, 9:59 am
Vehicle Year: 2000
Vehicle Make: Jeep
Vehicle Model: Grand

Re: New 4.6 Stroker Idles fine Stalls at stop lights/stop signs

Post by mrd05d » September 6th, 2021, 10:44 am

I load tested the battery and under the specified cca it was dropping to 6V... I replaced it and the rpm drop is gone.

The stalling is still there but better with the new batter. It is catching it before it stalls now 5/6 times. When it catches it the rpms are at like 200 then it bounces to 1000 then back down until it finds idle again or it stalls.

The Bosch 0280155849 are whats in there now and stft/ltft is at -33, So now I have a p0172 and p0175. The stock injectors were +22 stft/ltft. I am wondering if the ebay injectors are trash or if I need a different injector all together.

User avatar
Cheromaniac
Senior Member
Senior Member
Posts: 2980
Joined: March 8th, 2008, 12:58 pm
Stroker Displacement: 4563cc
Vehicle Year: 1992
Vehicle Make: Jeep
Vehicle Model: Cherokee
Location: Cyprus
Contact:

Re: New 4.6 Stroker Idles fine Stalls at stop lights/stop signs

Post by Cheromaniac » September 7th, 2021, 1:05 am

A STFT/LTFT of -33 suggests that the ECU is reducing the injector duty cycle 'cause the engine's running too rich, so it seems your Bosch 849 injectors (flow 26lb/hr at 49psi) are too big. Your stock 22.5lb injectors are too small so it looks like you need injectors that flow 24lb/hr at 49psi, and the Bosch 703 are just the right size.
1992 XJ 4.6 Stroker - 5MT - Stroker build-up, Stroker "recipes" Sold :cry:
2006 Mustang GT - 5MT - Modded
midlife crisis car. :D

mrd05d
Posts: 7
Joined: December 18th, 2020, 9:59 am
Vehicle Year: 2000
Vehicle Make: Jeep
Vehicle Model: Grand

Re: New 4.6 Stroker Idles fine Stalls at stop lights/stop signs

Post by mrd05d » September 7th, 2021, 6:09 am

Thanks for the reply. The tech specs page shows the the 784 is 26.3lb hr @ 43.5psi I have read elsewhere that 703s is ev1 and the 784 is ev6 with 23lb flow rate at 43.5psi. Do I need to get the 784s because of the ev6 or do I get the 703s and rewire the injector pigtails?

The tech specs page:
Bosch 0280155703 22.7lb/hr @ 43.5psi
Bosch 0280155784 26.3lb/hr @ 43.5psi

The image below I found in cherokeeforum.com shows it as 22.5lb @43.5 psi.
Image

Sorry for my confusion but much of the information out there seems contradictory.
You do not have the required permissions to view the files attached to this post.

User avatar
Cheromaniac
Senior Member
Senior Member
Posts: 2980
Joined: March 8th, 2008, 12:58 pm
Stroker Displacement: 4563cc
Vehicle Year: 1992
Vehicle Make: Jeep
Vehicle Model: Cherokee
Location: Cyprus
Contact:

Re: New 4.6 Stroker Idles fine Stalls at stop lights/stop signs

Post by Cheromaniac » September 8th, 2021, 12:02 am

OK, it seems you're right about the 784 injectors. They're basically the same as the 703 but with an EV6 connector instead of an EV1.
1992 XJ 4.6 Stroker - 5MT - Stroker build-up, Stroker "recipes" Sold :cry:
2006 Mustang GT - 5MT - Modded
midlife crisis car. :D

mrd05d
Posts: 7
Joined: December 18th, 2020, 9:59 am
Vehicle Year: 2000
Vehicle Make: Jeep
Vehicle Model: Grand

Re: New 4.6 Stroker Idles fine Stalls at stop lights/stop signs

Post by mrd05d » September 8th, 2021, 6:38 am

Sweet i have them on their way. Hopefully that fixes the super rich running condition. Then I will be back to attacking the stalling issue.

Thanks

mrd05d
Posts: 7
Joined: December 18th, 2020, 9:59 am
Vehicle Year: 2000
Vehicle Make: Jeep
Vehicle Model: Grand

Re: New 4.6 Stroker Idles fine Stalls at stop lights/stop signs

Post by mrd05d » September 11th, 2021, 12:32 pm

The 784s are in. I cleared adaptive tps and iac count. Fuel trims look decent now +3 to +6 ish at idle.

It did not stall this time but still is catching and hunting after driving for a few and coming back down to idle. It seemed to do it more when stopping down hill but that could have just been a coincidence.

I also noticed a different issue. Transmission is missing gear shift if I am at wot from a stop. If i wot when already moving it will shift fine...

TPS % goes to 0% when I let off the gas and seems to respond accurately when I am accelerating/decelerating. IAC steps matches target IAC steps pretty much at all times. (and I already replaced both iac/tps with Mopar sensors as well as thoroughly cleaned TB)

Any thoughts/help to get this thing running mint is appreciated.

User avatar
Cheromaniac
Senior Member
Senior Member
Posts: 2980
Joined: March 8th, 2008, 12:58 pm
Stroker Displacement: 4563cc
Vehicle Year: 1992
Vehicle Make: Jeep
Vehicle Model: Cherokee
Location: Cyprus
Contact:

Re: New 4.6 Stroker Idles fine Stalls at stop lights/stop signs

Post by Cheromaniac » September 12th, 2021, 12:49 am

Hopefully the idle will settle down as the ECU completes its adaptive learning. As for the transmission issue, my knowledge is limited but a faulty transmission range sensor could cause those symptoms. If it's mounted on the outside of the transmission, cleaning the contacts of any dirt/contaminants may solve the issue.
1992 XJ 4.6 Stroker - 5MT - Stroker build-up, Stroker "recipes" Sold :cry:
2006 Mustang GT - 5MT - Modded
midlife crisis car. :D

Post Reply

Who is online

Users browsing this forum: No registered users and 9 guests