Welcome to www.JeepStrokers.com!!
Not yet a registered user? You are required to Register before you can post within this topic.

Tuning with MS3X

Performance mods and Advanced Stroker discussion.
User avatar
The Beast
Learning to use the board
Learning to use the board
Posts: 35
Joined: October 12th, 2011, 2:00 pm
Stroker Displacement: 4.7
Vehicle Year: 1988
Vehicle Make: Jeep
Vehicle Model: Cherokee
Location: Guelph ON Canada

Re: Tuning with MS3X

Post by The Beast » February 1st, 2019, 9:24 am

:doh: :doh: :doh: :doh: :doh: :doh: :doh: :doh: :doh: :doh:
My Jeep is like having a conversation with two lions, in both my ears, inside my head, from the outside.... I hear good things from them!

User avatar
The Beast
Learning to use the board
Learning to use the board
Posts: 35
Joined: October 12th, 2011, 2:00 pm
Stroker Displacement: 4.7
Vehicle Year: 1988
Vehicle Make: Jeep
Vehicle Model: Cherokee
Location: Guelph ON Canada

Re: Tuning with MS3X

Post by The Beast » February 1st, 2019, 9:30 am

I guess my brain doesn't work as well as I want it to lol. Guess where I found this?
Some of you might recognize it...
Renix Crand and Cam Sync Waveform.png
Right in my own Renix FI Manual......... Sooooooooooo..

Made a little diagram for myself. Something like a little quick and dirty to place
on my phone for reference.
RENIX EFI Crank Timing.jpg
On top of the that, the notches are used for telling the ECM that it's 12 teeth before TDC, pretty much it.

Now I can fiddle with some other stuff finally.

That waveform and timing events diagram I will clean up and make a nice legible one to post.
You do not have the required permissions to view the files attached to this post.
My Jeep is like having a conversation with two lions, in both my ears, inside my head, from the outside.... I hear good things from them!

LRSimons
Making Progress
Making Progress
Posts: 57
Joined: September 14th, 2017, 5:52 pm
Vehicle Year: 1995
Vehicle Make: Jeep
Vehicle Model: XJ

Re: Tuning with MS3X

Post by LRSimons » February 2nd, 2019, 6:50 pm

Curious, why are you running a spark box? Seems like the MS should have no problem controlling spark directly.

User avatar
The Beast
Learning to use the board
Learning to use the board
Posts: 35
Joined: October 12th, 2011, 2:00 pm
Stroker Displacement: 4.7
Vehicle Year: 1988
Vehicle Make: Jeep
Vehicle Model: Cherokee
Location: Guelph ON Canada

Re: Tuning with MS3X

Post by The Beast » February 4th, 2019, 3:54 pm

I had the box with the ss coil. I just decided to wire into the ICM then to the box. I'm just using all my stuff. It works fine and gets good spark.

Also an update on the cam sync sensor. The one I got from parts was either wrong or it's buggered somehow. It came with a new distributor
assembly which was cheaper. I used my old one which works fine and works properly without a pullup on it because it has one built in already.
Gray=12v
Blue=Cam
gnd=gnd
The other one I don't know what it was maybe some kind of weird Chrysler one. Whatever, I used the new housing and put my old sensor in there
and made an adjustable mount bar for the sync generator. Works a lot better.

Tried to get it running today, no sync loss or anything but it just refuse to run. I checked the plugs and one was firing and the others were clean
and wet. I'm not sure what the means yet but I got another set of plugs to try and see if that fixes or improves the issue. Oddly enough the
5th plug was the only one that fired consistently and sometimes 3rd plug. :huh:

Maybe later tonight I'll go back out and see but I need a break lol..
My Jeep is like having a conversation with two lions, in both my ears, inside my head, from the outside.... I hear good things from them!

User avatar
The Beast
Learning to use the board
Learning to use the board
Posts: 35
Joined: October 12th, 2011, 2:00 pm
Stroker Displacement: 4.7
Vehicle Year: 1988
Vehicle Make: Jeep
Vehicle Model: Cherokee
Location: Guelph ON Canada

Re: Tuning with MS3X

Post by The Beast » February 7th, 2019, 4:44 pm

KK I got it running again. Good robust idle at around 650-700rpm at 13.5 degrees timing and an AFR at around 13.5 - 14.
I haven't touched the cranking fuel much since after resetting it but it looks like this motor likes to see a lot of fuel
and then lean out quite a bit once running. My table is wrecked but autotune will straighten that out fairly quick.
I've already used it to clean up my idle-off idle area and it doesn't smell nasty rich like the old ECM was producing.

The only thing left to do is play with the AE setting to remedy the hesitation it has, something the old ECM did as well.
I'll be happy to get rid of that finally after all these years with the stroker lol.

The only current problem I have left is this weird rev limiting anomaly that's happening. No matter how I peddle it
it has a hard rev wall at 1750-1800rpm, can't even push through it. I get a few pops here and there but it acts
exactly like a set rev limiter. Gonna play with the distributor a bit tomorrow to see if that wall moves with it (I hope lol)
because I thinking it might be a sync issue.

Little bit of progress is always good. I'm happy I can get it to start and idle on it's own and no hunting or stalling after
throttle stabs; all present which when the stock computer was in there.

Once I clear this little issue up I'll post a tune and put together some logs and settings that should be a good start for others
to use\look at if they wish.

:cheers:
My Jeep is like having a conversation with two lions, in both my ears, inside my head, from the outside.... I hear good things from them!

User avatar
SkylinesSuck
Donator
Donator
Posts: 443
Joined: February 14th, 2009, 11:11 pm
Stroker Displacement: 4.6L
Vehicle Year: 1998
Vehicle Make: Jeep
Vehicle Model: Wrangler
Location: Northern VA

Re: Tuning with MS3X

Post by SkylinesSuck » February 7th, 2019, 7:53 pm

Congrats on the progress!

User avatar
The Beast
Learning to use the board
Learning to use the board
Posts: 35
Joined: October 12th, 2011, 2:00 pm
Stroker Displacement: 4.7
Vehicle Year: 1988
Vehicle Make: Jeep
Vehicle Model: Cherokee
Location: Guelph ON Canada

Re: Tuning with MS3X

Post by The Beast » February 12th, 2019, 10:56 am

Got my "rev-limiting" problem sorted out! All I had to do was run a 220ohm resister across the leads to clean up the signal.
Cranks and free revs now :D. Instead of soldering on the harness I ran them off the board instead.
20190212_134511[1].jpg
The shunt is connected to pin1 and pin24 on the Mainboard, this is the 3.57v. **Turn the R56/R52 conditioners all the way CCW**
20190212_134711[1].jpg
The weather is terrible so can't do any drive tuning yet but maybe on the weekend might be warm enough and clear.
You do not have the required permissions to view the files attached to this post.
My Jeep is like having a conversation with two lions, in both my ears, inside my head, from the outside.... I hear good things from them!

User avatar
The Beast
Learning to use the board
Learning to use the board
Posts: 35
Joined: October 12th, 2011, 2:00 pm
Stroker Displacement: 4.7
Vehicle Year: 1988
Vehicle Make: Jeep
Vehicle Model: Cherokee
Location: Guelph ON Canada

Re: Tuning with MS3X

Post by The Beast » February 20th, 2019, 9:57 am

Took it for a test toast yesterday evening and a funny thing happened before I left.

I started it and let it run like always do but I was getting an issue with the oilpan leaking. So I was like "ehh, whatever, tighten a few bolts lol"
I jack her up and get underneath tighten said bolts and so done'n'done. Fire it up again and take a look few minutes later no leaks, ok. Went
inside to grab some things and when I came out,.. boom! little black spot, again!? Kept it running and went underneath with a rag cleaned
it up and noticed something strange. I can see the leak happening pretty fast and it was coming from the heads of the bolts. I was like WTF
that's a new Felpro gasket and everything. I was like hmm, then I turned the oil cap and it blew up and into my hand as I pulled it away.
Right then and there I had that little cold pit in behind your balls, first thing in my mind was I have to tear this thing apart again. :shock: :x

Well I was like hold on a minute this didn't happen before on the old ECM so I checked the hoses and found that some wern't sucking and
blowing like they were supposed to be. After a few little tests and swaps I found that a line had water frozen in the line to my oil/air
separator from condensation cycle over the last month of starting. As soon as I bypassed and ran straight to the intake the oil cap was
vacuum sucked to the valve cover, so I left it for now. But I haven't had a cold pit feel like that since my mom had my Jeep towed caused
I used it before I got my license hehehe.

The Jeep is fine and runs really really good! Once that was figured out I drove it around the neighborhood for a bit to run the auto-tune
feature in TS. It responded fairly well and I've noticed it took quite a bit of fuel out at the bottom low to mid throttle and vacuum.
I haven't hit the top end yet but couldn't really because it's too cold out and no traction to put under load. I might have to put the
track tires back on this weekend when it warms up. I'm hoping it'll be dry so I get enough traction to tune WOT.

The only issue left (like I haven't said that before ;p) is the low idle speed. Can't seem to get it to stay at least above 650-700rpm.
It doesn't do anything bad at low rpm idle I even had a steady idle at 480rpm but I prefer to have it around 800rpm. The only thing
left that I can think of to mess with is the ignition. It's already at 14.8 degrees, should I go higher for faster idle? I've seen some
cars use quite a bit of timing but were some oddball weird Jap motors but even common ones like 1-2j's or Miata's. I can't imagine
it hurting the motor but wouldn't doing that cobble band-aid the tune and create weird table anomalies? I'll try it anyway but will report
weirdness if any.

The great thing so far is that super lazy response and quirky AFR problems of the old ECU are gone and letting off the gas it doesn't
stall coming to light and such. Drivability is 3 times that of the old ECU. I may like to hang up on the wall my good'ol Renix ECU and
shine er up real nice but I'm glad that thing is retired now.

Besides all that and this very long post I will post my current tune to date. SO if anyone wants to try it I'd say it's good enough to help
someone get the wheels spinning before it hit the ground so to speak.

Just to NOTE** This is a N/A tune, NOT for turbo's or superchargers!*****
I will make one of those later hehe :hrhr:
88XJ CurrentTune.rar
You do not have the required permissions to view the files attached to this post.
My Jeep is like having a conversation with two lions, in both my ears, inside my head, from the outside.... I hear good things from them!

User avatar
The Beast
Learning to use the board
Learning to use the board
Posts: 35
Joined: October 12th, 2011, 2:00 pm
Stroker Displacement: 4.7
Vehicle Year: 1988
Vehicle Make: Jeep
Vehicle Model: Cherokee
Location: Guelph ON Canada

Re: Tuning with MS3X

Post by The Beast » February 27th, 2019, 3:55 pm

OK so the other day I fixed the idle issue. Actually it was more of an "ME" issue lol. I totally forgot that the idle motor needs
to 'close' for it to let more air bypass. Brain farted and was cranking up the idle duty steps trying to get it raise the idle lol.
I set it properly and ended putting it at around 80 steps from closed which is near full open. It'll idle around 700rpm now.

In TS I had to swap the ramp on the table around top small numbers (80ish) and the bottom is at (220) steps. The idle
valve housing is stock Renix dimensions and uses the original Renix idle motor. So your ramp will depend on where your
inlet will be.

I got another road tune in there and adjusted my ignition map a bit and it seems to work noticeably better. I still don't know
if the ignition is too conservative or close to optimal. I guess I'll figure that out with a good day and clean flat lonely road.
The fuel map I had just redone making some adjustments and smoothed out the transients. I will test those out later when
the weather is good enough and somewhat clean.

After this test I will post up another log and tune file. The last one is a little jenky but people could still use to get started, this
one should be good enough for reliable driving before going to the dyno or a decent start to dial it in for DDing.
My Jeep is like having a conversation with two lions, in both my ears, inside my head, from the outside.... I hear good things from them!

User avatar
The Beast
Learning to use the board
Learning to use the board
Posts: 35
Joined: October 12th, 2011, 2:00 pm
Stroker Displacement: 4.7
Vehicle Year: 1988
Vehicle Make: Jeep
Vehicle Model: Cherokee
Location: Guelph ON Canada

Re: Tuning with MS3X

Post by The Beast » March 13th, 2019, 9:33 pm

Weather is getting better. I'm still in the process of testing. I changed my ignition map again and I have refined it more to help with daily driving.
It drives fairly easy now and have been making fine adjustments to the fuel and smoothing out transients for better operation. At the moment
I'm trying to figure out closed loop idle it's a little weird and control is indirect so when I understand how it works better in Megasquirt I'll just
keep it in open loop.

Today I did go out for a drive but picked a bad time, all the traffic, unbelievable where all these people come from geez. But in any case couldn't
get any real pulls done and it started to rain so yeah. Up to about 4500rpm drivablilty is like a newish stock Cherokee, it just works. Aside from
that though the injectors are undersized which is a shame cause they are the 12 holes lol but running at 70-80% most of the time when in
spirited mode is no bueno before you matt it at WOT, 5000+rpm at 95/kpa equals %100 and the AFR starts to creep up fairly quickly at 5500rpm.

I'd like to see 50-60% and 80% at max WOT up to 6200. Need bigger injectors and fuel pump for sure lol. I'll post another tune later but I want to
make some timed pulls to start zeroing in closer to making peak power. Maybe a couple of weeks.
My Jeep is like having a conversation with two lions, in both my ears, inside my head, from the outside.... I hear good things from them!

User avatar
SkylinesSuck
Donator
Donator
Posts: 443
Joined: February 14th, 2009, 11:11 pm
Stroker Displacement: 4.6L
Vehicle Year: 1998
Vehicle Make: Jeep
Vehicle Model: Wrangler
Location: Northern VA

Re: Tuning with MS3X

Post by SkylinesSuck » March 14th, 2019, 3:44 am

What size injectors do you have now?

User avatar
The Beast
Learning to use the board
Learning to use the board
Posts: 35
Joined: October 12th, 2011, 2:00 pm
Stroker Displacement: 4.7
Vehicle Year: 1988
Vehicle Make: Jeep
Vehicle Model: Cherokee
Location: Guelph ON Canada

Re: Tuning with MS3X

Post by The Beast » March 14th, 2019, 6:38 am

I have the Ford 12 hole 0-280-156-161. 23.5# They're nice injectors really, takes less fuel to start. Probably due to their large fan pattern. Rail is roughly 42lbs. at least that's what the gauge says. I'm leaning towards the Ford 0-280-156-127 39#.
My Jeep is like having a conversation with two lions, in both my ears, inside my head, from the outside.... I hear good things from them!

User avatar
SkylinesSuck
Donator
Donator
Posts: 443
Joined: February 14th, 2009, 11:11 pm
Stroker Displacement: 4.6L
Vehicle Year: 1998
Vehicle Make: Jeep
Vehicle Model: Wrangler
Location: Northern VA

Re: Tuning with MS3X

Post by SkylinesSuck » March 14th, 2019, 2:00 pm

I've got some Ford f55e-a2d's if you want for cheap. They are pintile so I know you probably don't want to "downgrade" but just thought I'd mention. No even sure how much bigger they are than what you have now actually.

User avatar
The Beast
Learning to use the board
Learning to use the board
Posts: 35
Joined: October 12th, 2011, 2:00 pm
Stroker Displacement: 4.7
Vehicle Year: 1988
Vehicle Make: Jeep
Vehicle Model: Cherokee
Location: Guelph ON Canada

Re: Tuning with MS3X

Post by The Beast » March 14th, 2019, 4:40 pm

Those F55E-A2D's are basically the same one's I had before. They were pretty good till they got gummed up from sitting for nearly 2 years lol.
They're just EV1 24# 4.6 injectors.

The 04' Cobra ones are USCAR plugs and good for 500+hp. So for me using 6 injectors probably shouldn't hurt for around 400 tire
with supercharging. They will work better for NA 300 tire. My PW are around 5ms idle (is OK) to 26ms up at 5000rpm lol, not too good lol.
My Jeep is like having a conversation with two lions, in both my ears, inside my head, from the outside.... I hear good things from them!

Post Reply

Who is online

Users browsing this forum: Baidu [Spider], Bing [Bot] and 3 guests