Welcome to www.JeepStrokers.com!!
Not yet a registered user? You are required to Register before you can post within this topic.

cranksensor

Dedicated forum for all things electrical... Sometimes Electrical issues can really get you stumped! Not Stroker related.
rammit11
Donator
Donator
Posts: 114
Joined: April 27th, 2010, 4:29 pm
Stroker Displacement: 4.6
Vehicle Year: 1998
Vehicle Make: jeep
Vehicle Model: cherokee
Location: southeastern pennsylvania

cranksensor

Postby rammit11 » May 6th, 2017, 7:22 pm

Hi, was looking to see if anyone has an answer to a question I have on a possible crank sensor issue. I am trying to find out if the crank sensor could cause an excessive timing condition. My sensor has a good deal of millage on it and occasionally the engine has a hard start condition and after this happens it seems to have a better run quality. I have verified that my fuel pressure is as it should be. The other issue I get that seems to disappear is a pinging under heavy load as what used to happen on older enigines when timing is advanced to far. Thanks for any insights on this ,Dave.

User avatar
SkylinesSuck
Donator
Donator
Posts: 268
Joined: February 14th, 2009, 11:11 pm
Stroker Displacement: 4.6L
Vehicle Year: 1998
Vehicle Make: Jeep
Vehicle Model: Wrangler
Location: Northern VA

Re: cranksensor

Postby SkylinesSuck » May 7th, 2017, 4:37 pm

What year Jeep?

rammit11
Donator
Donator
Posts: 114
Joined: April 27th, 2010, 4:29 pm
Stroker Displacement: 4.6
Vehicle Year: 1998
Vehicle Make: jeep
Vehicle Model: cherokee
Location: southeastern pennsylvania

Re: cranksensor

Postby rammit11 » May 7th, 2017, 6:34 pm

Sorry about that , It is a 1998 with a 4.6 stroker .


Return to “Electrical”

Who is online

Users browsing this forum: No registered users and 1 guest